вторник, 29 декабря 2009 г.

Странности в gentoo-lisp-overlay

Что-то стали в gentoo-lisp-overlay кривые пакеты попадаться: для bordeaux-threads-0.7.0 файл с версией не копируется, для parenscript-20090921 зависимости не указаны... Как они их делаю?.. Точнее, как делают понятно, но почему не проверяют - вот это мне не понятно. И исправлений никаких уже долго нет, один я что-ли им пользуюсь... Эх, фиксю и помещаю исправления в свой форк.

5 комментариев:

  1. последняя версия closer-mop вызывает конфликт имен с cl-gtk2 если я не ошибаюсь. это в gentoo-lisp-overlay и в форке.

    ОтветитьУдалить
  2. @LiteTabs
    Хм, а можно поподробней? Вообще, это, конечно, надо к dmitry_vk с этим...

    ОтветитьУдалить
  3. это я к слову сказал. подробно разобраться в ошибке опыта не хватило, я просто поставил closer-mop чуть постарее и продолжил работу.

    ОтветитьУдалить
  4. @LiteTabs
    Да, уже разобрались, и опять упрёк в сторону разработчиков gentoo-lisp-overlay: они просто переименовали ebuild для более старой версии closer-mop и не оставили возможность выбирать между версиями. Теперь будем ждать, пока dmitry-vk выпустит промежуточный релиз.

    ОтветитьУдалить
  5. Разработчики g-l-o тут совсем не причем. Надо было сразу в cl-gtk2 правильно использовать closer-mop.

    ОтветитьУдалить